Seiten: 12nächste Seite
Aktuelle Seite: 1 von 2
Login bei Cyrus funktioniert nicht?
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 14:55

Hallo, ich habe mich durch die Group-E-Installation geschlagen und
bin bis auf ein paar Ungereimtheiten mit den Namen groupe und group-e in der Installationsanleitung gut durchgekommen. Das Produkt sieht auch sehr gut aus!

Leider erhalte ich beim Install-Check immer eine Fehlermeldung im Zusammenhang mit Cyrus:

cyrus_login BAD UNEXPECTED IMAP-SERVER-ERROR SENT COMMAND:. login cyrus "meinPasswort" SERVER RETURNED: . NO Login failed: authentication failure

Es sieht ja sehr danach aus als würde das PW nicht stimmen, aber es ist 100% unter Konfiguration dasselbe eingetragen wie für den Systemuser "cyrus". Und sonst muss ich es nicht irgendwo noch eintragen oder?

MfG

trunky

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 14:56

Probieren Sie mal auf der Kommandozeile:
cyradm --user cyrus localhost

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 14:56

Ja danke, bin seit Stunden dabei Google zu wälzen, über die Konsole kriege ich auch keinen Zugriff.
Wundere mich nur, da ich einen neuen Server aufgesetzt habe und nur die Standardscripts von Group-E kopiert habe... :?

MfG

trunky

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 14:57

Probieren Sie auf der Kommandozeile:
getent passwd cyrus

Sollte ungefähr so aussehen:
cyrus:x:108:8:Cyrus Mailsystem User,,,:/var/spool/cyrus:/bin/sh

Ist folgendes möglich:
su - cyrus

Was steht im Logfile /var/log/auth.log

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 14:57

Die ersten beiden Befehle funktionieren und geben auch Sinnvolles.

/var/log/auth.log gibt es nicht bei mir (Debian 4.0), dafür steht was in /var/log/messages drin.

Leider kann man hier keine Logs posten? Das Forum mecker zumindest immer rum, ich müssen den Beitrag ausfüllen... :(

MfG trunky

perl: no worthy mechs found
saslauthd[1656]: PAM (imap) illegal module type: db=group-e
saslauthd[1656]: PAM pam_parse: expecting return value; [...table=auth_user_md5]
saslauthd[1656]: PAM unable to dlopen(/lib/security/usercolumn=username)
saslauthd[1656]: PAM [dlerror: /lib/security/usercolumn=username: cannot open shared object file: No such file or directory]
saslauthd[1656]: PAM adding faulty module: /lib/security/usercolumn=username
saslauthd[1656]: PAM (imap) illegal module type: where=activ=1
saslauthd[1656]: PAM pam_parse: expecting return value; [...account]
saslauthd[1656]: PAM unable to dlopen(/lib/security/required)
saslauthd[1656]: PAM [dlerror: /lib/security/required: cannot open shared object file: No such file or directory]
saslauthd[1656]: PAM adding faulty module: /lib/security/required
saslauthd[1656]: PAM (imap) illegal module type: db=group-e
saslauthd[1656]: PAM pam_parse: expecting return value; [...table=auth_user_md5]
saslauthd[1656]: PAM (imap) illegal module type: where=activ=1
saslauthd[1656]: PAM (imap) no control flag supplied
saslauthd[1656]: PAM (imap) no module name supplied
saslauthd[1656]: PAM unable to dlopen( < *unknown module path * > )
saslauthd[1656]: PAM [dlerror: < *unknown module path* >: cannot open shared object file: No such file or directory]
saslauthd[1656]: PAM adding faulty module: < *unknown module path* >
saslauthd[1656]: (pam_unix) authentication failure; logname= uid=0 euid=0 tty= ruser= rhost= user=cyrus
saslauthd[1656]: do_auth : auth failure: [user=cyrus] [service=imap] [realm=] [mech=pam] [reason=PAM auth error]

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 14:58

Also folgendes:
Schauen Sie mal in Ihre PAM Konfigurationsdateien

Die Einstellung in etc/pam.d/imap :

auth sufficient pam_mysql.so user=pam passwd=YOUR_PAM_PASSWORD host=localhost
db=group-e table=auth_user_md5 usercolumn=username passwdcolumn=password md5=Y
where=activ=1

muss alles in einer Zeile stehen.

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 14:58

So einfach und doch so fern! Ich danke vielmals!!

In der Konfiguration zeigt es mir jetzt ok an, wenn ich allerdings einen Benutzer anlege und der auf Email zugreifen kann kriege ich die Meldung

"Es ist folgender Fehler aufgetreten: "IMAP: Too many login failures" Wenden Sie sich an den Administrator"

Muss ich die Benutzer nicht nur im Group-E-Adminbereich anlegen, sondern noch woanders? Oder paßt da immer noch was nicht? :(
Das Log sagt "(pam_unix) check pass; user unknown"
"(pam_unix) authentication failure; logname= uid=0 euid=0 tty= ruser= rhost="

MfG

trunky

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 14:59

Checken Sie folgende daten Ihrer etc/pam.d/imap

auth sufficient pam_mysql.so user=pam passwd=YOUR_PAM_PASSWORD host=localhost
db=group-e table=auth_user_md5 usercolumn=username passwdcolumn=password md5=Y
where=activ=1

Ist ein Zugriff mit user=pam passwd=YOUR_PAM_PASSWORD auf mysql möglich?
mysql -u pam -p=YOUR_PAM_PASSWORD

Ist die Datenbank richtig
db=group-e
könnte auch
db=groupe sein (Ich weiss Dokumentation muss überarbeitet werden)

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 15:05

Habe es jetzt den Server neu aufgesetzt und mit Cyrus2.2 probiert (ansonsten PHP5, mySQL5) und erhalte jetzt im Config-Menu die Meldung

"UNEXPECTED IMAP-SERVER-ERROR SENT COMMAND:. login cyrus SERVER RETURNED: . BAD Unexpected extra arguments to LOGIN"

Komischerweise taucht in den Logs auch nichts mehr auf. Werde es wohl nochmal in ein paar virtuellen Maschinen nachstellen müssen :(
Alles andere habe ich schon durchgetestet, User pam und postfix in der Datenbank, User Cyrus ebenso, Cyradm funktioniert auch bestens.

MfG
trunky

BAD Unexpected extra arguments
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:06

Hast du das Password im config interface eingetragen (unter E-Mail)

Nix für ungut aber das sieht verdammt danach aus ;)

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 15:08

Ja, Zugriff auf die DB kann ich zugreifen mit dem User PAM und zwar auf die Tabelle auth_user_md5, wie gewünscht.
Die Datenbank heißt group-e, unter dem User config erhalte ich auch ein OK im Zugriff auf Cyrus.

Ich werde den Server nochmal neu aufsetzen und testen was dann passiert. Dabei versuche ich mal die Doku anzupassen und dann zur Verfügung zu stellen, wenns recht ist

MfG

trunky

Cyrus Problem
geschrieben von: (IP-Adresse bekannt)
Datum: 22. August 2007 15:10

Ich habe das gleiche Problem oder ähnlich:
UNEXPECTED IMAP-SERVER-ERROR SENT COMMAND:. login cyrus pentan SERVER RETURNED: . NO Login failed: generic failure

bei dem Befehl cyradm --user cyrus localhost
bekomme ich ähnliche fehlermeldung:
Login failed: generic failure at /usr/lib/perl5/Cyrus/IMAP/Admin.pm line 119
cyradm: cannot authenticate to server as cyrus

Cyrus Problem
geschrieben von: (IP-Adresse bekannt)
Datum: 22. August 2007 15:12

im log steht folgendes:
Apr 11 09:31:40 portal saslauthd[11387]: PAM (imap) illegal module type: db=groupe
Apr 11 09:31:40 portal saslauthd[11387]: PAM pam_parse: expecting return value; [...table=auth_user_md5]
Apr 11 09:31:40 portal saslauthd[11387]: PAM unable to dlopen(/lib/security/usercolumn=username)
Apr 11 09:31:40 portal saslauthd[11387]: PAM [dlerror: /lib/security/usercolumn=username: cannot open shared object file: No such file or directory]
Apr 11 09:31:40 portal saslauthd[11387]: PAM adding faulty module: /lib/security/usercolumn=username
Apr 11 09:31:40 portal saslauthd[11387]: PAM (imap) illegal module type: where=activ=1
Apr 11 09:31:46 portal saslauthd[11388]: PAM (imap) illegal module type: db=groupe
Apr 11 09:31:46 portal saslauthd[11388]: PAM pam_parse: expecting return value; [...table=auth_user_md5]
Apr 11 09:31:46 portal saslauthd[11388]: PAM unable to dlopen(/lib/security/usercolumn=username)
Apr 11 09:31:46 portal saslauthd[11388]: PAM [dlerror: /lib/security/usercolumn=username: cannot open shared object file: No such file or directory]
Apr 11 09:31:46 portal saslauthd[11388]: PAM adding faulty module: /lib/security/usercolumn=username
Apr 11 09:31:46 portal saslauthd[11388]: PAM (imap) illegal module type: where=activ=1
Apr 11 09:32:16 portal perl: No worthy mechs found
Apr 11 09:32:18 portal saslauthd[11384]: PAM (imap) illegal module type: db=groupe
Apr 11 09:32:18 portal saslauthd[11384]: PAM pam_parse: expecting return value; [...table=auth_user_md5]
Apr 11 09:32:18 portal saslauthd[11384]: PAM unable to dlopen(/lib/security/usercolumn=username)
Apr 11 09:32:18 portal saslauthd[11384]: PAM [dlerror: /lib/security/usercolumn=username: cannot open shared object file: No such file or directory]
Apr 11 09:32:18 portal saslauthd[11384]: PAM adding faulty module: /lib/security/usercolumn=username
Apr 11 09:32:18 portal saslauthd[11384]: PAM (imap) illegal module type: where=activ=1

Re: Cyrus Problem
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:12

Siehe oben:

Fehler in pam Konfiguration

Re: Cyrus Problem
geschrieben von: (IP-Adresse bekannt)
Datum: 22. August 2007 15:13

leider führt das zu keiner Änderung :-(

Re: Cyrus Problem
geschrieben von: (IP-Adresse bekannt)
Datum: 22. August 2007 15:15

seitdem steht im Log:

Apr 11 09:45:29 portal perl: No worthy mechs found
Apr 11 09:48:19 portal perl: No worthy mechs found
Apr 11 09:49:31 portal perl: No worthy mechs found

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 15:16

Zwischenstand:

1. hatte tatsächlich vergessen das PW anzugeben :(
2. Hänge wieder wie beim ersten Mal an der Meldung "Too many login failures" und komme nicht weiter

MfG

trunky

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:17

Kannst du mal die die gesamte etc/pam.d/imap posten.

Der Hund liegt sicher irgendwo bei der pam / saslauth Kofiguration begraben.

Such im Logfile mal nach irgendwelchen saslauth Fehlern.

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: (IP-Adresse bekannt)
Datum: 22. August 2007 15:19

Hier die /etc/pam.d/imap



auth sufficient pam_mysql.so user=pam passwd=pentan host=localhost db=groupe table=auth_user_md5 usercolumn=username passwdcolumn=password md5=Y where=activ=1

account required pam_mysql.so user=pam passwd=pentan host=localhost db=groupe table=auth_user_md5 usercolumn=username passwdcolumn=password md5=Y where=activ=1



Folgende Fehler stehen im auth.log:



Apr 12 13:10:08 com saslauthd[2029]: do_auth : auth failure: [user=bgross] [service=imap] [realm=] [mech=pam] [reason=PAM auth error]

Apr 12 13:10:15 com saslauthd[2030]: (pam_unix) check pass; user unknown

Apr 12 13:10:15 com saslauthd[2030]: (pam_unix) authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=

Apr 12 13:10:17 com saslauthd[2030]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module

Apr 12 13:10:17 com saslauthd[2030]: do_auth : auth failure: [user=bgross] [service=imap] [realm=] [mech=pam] [reason=PAM auth error]

Apr 12 13:10:20 com saslauthd[2031]: (pam_unix) check pass; user unknown

Apr 12 13:10:20 com saslauthd[2031]: (pam_unix) authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=

Apr 12 13:10:22 com saslauthd[2031]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module

Apr 12 13:10:22 com saslauthd[2031]: do_auth : auth failure: [user=bgross] [service=imap] [realm=] [mech=pam] [reason=PAM auth error]

Apr 12 13:10:25 com saslauthd[2032]: (pam_unix) check pass; user unknown

Apr 12 13:10:25 com saslauthd[2032]: (pam_unix) authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=

Apr 12 13:10:27 com saslauthd[2032]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module

Apr 12 13:10:27 com saslauthd[2032]: do_auth : auth failure: [user=bgross] [service=imap] [realm=] [mech=pam] [reason=PAM auth error]



Mir gehen die Ideen aus. Ich bitte um Hilfe.

pam imap
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:19

Mich hätte eigentlich interessiert was in der /etc/pam.d/imap
sonst noch steht?

steht da irgendwo so was ähnliches wie
auth required pam_unix.so shadow

sollte
auth sufficient pam_unix.so shadow use_first_pass
lauten

denn wenn da required steht dann heist das dass der user als unix user angelegt sein muss.

Da die normalen E-Mail user aber nur in der mysql datenbank existieren funktioniert das nicht.

Das würde auch erklären wieso es mit dem user cyrus funktioniert denn der existiert ja als unix user.

pam
geschrieben von: (IP-Adresse bekannt)
Datum: 22. August 2007 15:20

Sonst steht da nicht hier meine KOMPLETTE config:

# PAM configuration file for Cyrus IMAP service
# $Id: imap.pam 5 2005-03-12 23:19:45Z sven $
#
# If you want to use Cyrus in a setup where users don't have
# accounts on the local machine, you'll need to make sure
# you use something like pam_permit for account checking.
#
# Remember that SASL (and therefore Cyrus) accesses PAM
# modules through saslauthd, and that SASL can only deal with
# plaintext passwords if PAM is used.
#

@include common-auth
@include common-account

auth sufficient pam_mysql.so user=pam passwd=pentan host=localhost db=groupe table=auth_user_md5 usercolumn=username passwdcolumn=password md5=Y where=activ=1

account required pam_mysql.so user=pam passwd=pentan host=localhost db=groupe table=auth_user_md5 usercolumn=username passwdcolumn=password md5=Y where=activ=1

Re: pam
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:21

AHA!
@include common-auth
bindet die datei etc/pam.d/common-auth ein.

Dort bitte nachschauen und required in sufficent ändern.

Re: Login bei Cyrus funktioniert nicht?
geschrieben von: (IP-Adresse bekannt)
Datum: 22. August 2007 15:23

Ich rate von dieser Änderung ab! Seitdem bin ich nicht mehr in der Lage mich per ssh einzuloggen mein Passwort wird nicht mehr akzeptiert

und da es sich um einen VServer handelt werde ich das System neuinstallieren dürfen

Sämtliche Systemuser werden nicht mehr akzeptiert! Auch Cyrus nicht mehr!

Tschuldigung
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:23

Hab mich da wohl etwas vertan.
Habe das bei mir getestet und funktioniert.
Wird wohl an der kombination liegen.

Cyrus Problem
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:24

Ich hab mir das ganze mal genauer angeschaut.
Es sind mehrere Probleme:

1. die richtige Verschlüsselung bei den PAM Einträgen ist crypt=3 und nicht MD5=Y (hex MD5 und nicht crypt MD5, was immer das auch heißen mag)

2. bei Debian ist das pam_mysql buggy. Siehe bugs.debian.org/cgi-bin/bugreport.cgi?bug=373834
Ohne diesen Bugfix funktioniert crypt=3 nicht.

3. in der PAM-Konfigurationsdatei muss der mysql Eintrag vor den common* Einträgen stehen. Also so

auth sufficient pam_mysql.so user=... crypt=3..
account sufficient pam_mysql.so user=... crypt=3..
@include common-auth
@include common-account

Dann funktioniert alles... hoffentlich ;-)

Leider nicht
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 15:25

1. Der Bug-Eintrag ist vom Juli 2006, ich denke mal das wurde inzwischen bei Debian gefixt (spätestens in der 4.0 die ich benutze)

2. habe die imap angepaßt entsprechend, mit crypt=3 und include dahinter, keine Änderung leider :(
2.1 ohne include getestet funktioniert nicht mal mehr der Install-Check (logo, User Cyrus kann sich nicht mehr authentifizieren
2.2 in der common-auth und common-account required gegen sufficient getauscht, auch keine Verbesserung

Langsam bin ich echt ratlos, mein Projekt hätte schon stehen müssen *seufz*

MfG

trunky

Noch ein Versuch
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:25

Ich haben den Verdacht dass dass das crypten des passwords im pam_mysql Modul nicht richtig funktioniert.

Deshalb folgender Hackt:

In der Datei group-e/etc/phplib/lib/local.inc

$this->auth["password"]=$_POST['password'];

ersetzen durch

$this->auth["password"]=md5($_POST['password']);

in pam Konfiguration den Parameter

crypt=3 bzw. md5=Y entfernen.

Login mit group-e versuchen.

lg

Re: Leider nicht
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:26

Umstellung von MD5 auf MYSQL-Password:

1. In der Datei www/cfg/global.inc.php folgenden Wert auf true setzen:
$CFG['MPASSWD']=true;

2. Password von sysadmin zurücksetzen:
mysql -u root -p
mysql> use groupe;
mysql> UPDATE `auth_user_md5` SET `password` =
PASSWORD( 'sysadmin' );
mysql> exit;

3. in der PAM-Konfigurationsdatei /etc/pam.d/imap /etc/pam.d/sieve
den Parameter crypt auf 2 setzen:

auth sufficient pam_mysql.so user=... crypt=2..
account sufficient pam_mysql.so user=... crypt=2..
@include common-auth
@include common-account

4. Als sysadmin einloggen und in der Amministration alle Passwörter
von bereits eingerichteten usern neu setzen.


HINWEIS: Dies betrifft nur Installationen die mit INSTALL.Mysql erstellt worden sind und eine Versionsnummer < 1.632 haben.

Neuinstallationen mit Version 1.632 werden automatisch mit MYSQL-Passwörtern installiert.

Installationen mit INSTALL.LDAP funktionieren einwandfrei. Wir empfehlen grundsätzilch die LDAP Installation um alle Features von group-e voll nutzen zu können.
(SAMBA-WebClient, Gruppenrechte auf Mailboxen).

Re: Leider nicht
geschrieben von: trunky (IP-Adresse bekannt)
Datum: 22. August 2007 15:27

Also mit meiner inzwischen vermurksten Installation klappt das auch nicht, ich erhalte schon beim und nach dem Ändern der Passwörter im oberen Bereich die Fehlermeldung:

"Es ist folgender Fehler aufgetreten:
Wenden Sie sich an den Administrator.

UNEXPECTED IMAP-SERVER-ERROR
SENT COMMAND:. login cyrus 'PASSWORD'
SERVER RETURNED:
. NO Login failed: generic failure"

Ich setze den Server mal wieder neu auf und teste es dann nochmal :)

MfG

trunky

PS: WO gibt es denn die Version 1.632????

Re: Leider nicht
geschrieben von: Support (IP-Adresse bekannt)
Datum: 22. August 2007 15:28

Bei
@include common-auth
@include common-account

Bitte nicht das @ voreher weglassen

Seiten: 12nächste Seite
Aktuelle Seite: 1 von 2


Ihr vollständiger Name: 
Ihre E-Mail-Adresse: 
Thema: 
Spamschutz:
Bitte gib den Code aus dem unten stehenden Bild in das Eingabefeld ein. Damit werden Bots, die versuchen dieses Formular automatisch auszufüllen, geblockt. Wenn der Code schwer zu lesen ist, versuche einfach zu raten. Wenn du einen falschen Code eingibst, wird einfach ein neues Bild erzeugt und du bekommst eine zweite Chance.