E-Mail einrichten
geschrieben von: iso (IP-Adresse bekannt)
Datum: 28. November 2008 12:15

Hallo Leute,

ich mache schon seit geraumer Zeit an diesem Problem herum...komme auf keine Art und weise weiter...
Mein Problem:
wenn ich mich als sysadmin einlogge und dann auf E-Mail klicke erscheint folgende

Fehlermeldung:
Es ist folgender Fehler aufgetreten: „IMAP: Can't open mailbox {mail.genotec.ch:143 /tls/novalidate-cert }: invalid remote specification”

oder
„IMAP: Certificate failure for mail.genotec.ch: unable to get local issuer certificate: /C=CH/ST=Baselland/L=Allschwil/O=Genotec Internet Consulting AG/OU=Hosting Services/CN=*.genotec.ch”

also an der Porteinstellung kann es nicht sein...denke ich zumindest...smile

wo muss ich was einstellen? Ich bin ein Greenhorn...smile


Einstellungen:
im config...ist alles auf ok
"auch cyrus_login"

Gruss
Iso

Re: E-Mail einrichten
geschrieben von: xtra (IP-Adresse bekannt)
Datum: 01. Dezember 2008 10:09

Du versuchst eine IMAP Session per TLS zu starten. Beim validieren des Zertifikats gibt es jedoch ein Problem und die Verbindung wird abgebrochen.

Bitte ueberpruefe deine TLS Konfiguration vom Cyrus oder aber lasse lokal unverschluesselten Zugriff auf den Cyrus IMAPd zu.

Gruss
Chris

Re: E-Mail einrichten
geschrieben von: iso (IP-Adresse bekannt)
Datum: 02. Dezember 2008 10:28

Hallo Cris,


danke für deine Antwort.
Kannst du mir bitte sagen was TLS heisst?

Wie und wo muss ich die Konfiguration kontrollieren?
Was müsste drin stehen...?

Das ist absolutes Neuland für mich....smile jeder fängt mal klein an...smile

Ich bitte dich um eine ausführliche Beschreibung....

danke nochmals.

Gruss
Iso

Re: E-Mail einrichten
geschrieben von: schmunzler (IP-Adresse bekannt)
Datum: 03. Dezember 2008 17:24

Hallo Iso,

TLS bedeutet, dass die IMAP-Zugriffe über eine verschlüsselte Verbindung erfolgen. Gegebenfalls funktioniert der Zugriff per TLS über Port 143 nicht richtig. Alternativ geht auch ssl über Port 993.

Verwendest Du ein selbst signiertes Zertifikat? Wenn ja, dann liegt es eventuell an der standard Einstellung von PHP. Diese überprüft das Zertifikat und beschwert sich sobald die ausstellende Instanz nicht verifiziert werden kann - sprich es fehlt das Zertifikat der CA.

Du kannst über den Konfiguationsbereich - anmelden als "config" unter Konfiguration -> E-mail bei Mail-Port folgendes eintragen: 993/imap/ssl/novalidate-cert

Relevant ist hierbei die Option "novalidate-cert" welche PHP anweist auf eine Validierung des Zertifikats zu verzichten.

Versuche alternativ mit einem Email-Programm wie Thunderbird den Zugriff auf den IMAP-Server unverschlüsselt, mit SSL, mit TLS.

Re: E-Mail einrichten
geschrieben von: iso (IP-Adresse bekannt)
Datum: 03. Dezember 2008 21:06

Hallo Schmunzler,

danke für deine Antwort.
Nun, ich habe den Eintrag gemacht und erhalte dieser Meldung:
"„IMAP: Can't open mailbox {mail.genotec.ch:993/imap/ssl/novalidate-cert }: invalid remote specification”"
sind diese Eintragungen ok?

Mail Server mail.genotec.ch
Mail Port 993/imap/ssl/novalidate-cert
Admin User ***@88lanpower.ch
Admin Password *******
Box Delimiter .
Domainname 88lanpower.ch
Alias Type Mysql

User und Passwort ist beim Provider ein E-Mail Konto....

Mit Thunderbird konnte ich problemlos die Mail holen... TLS und SSL, mit und ohne verschlüsselung...
Auf anhieb...smile

Was muss ich in der Config genau einstellen? sind noch weiter Einstellungen zu machen?
Am liebsten währe mir ein Printscreen auf dem ich sehen könnte, was eingestellt werden muss...smile iso@88lanpower.ch


Gruss
Iso



Ihr vollständiger Name: 
Ihre E-Mail-Adresse: 
Thema: 
Spamschutz:
Bitte gib den Code aus dem unten stehenden Bild in das Eingabefeld ein. Damit werden Bots, die versuchen dieses Formular automatisch auszufüllen, geblockt. Wenn der Code schwer zu lesen ist, versuche einfach zu raten. Wenn du einen falschen Code eingibst, wird einfach ein neues Bild erzeugt und du bekommst eine zweite Chance.