samba zugriff auf den group-e server
geschrieben von: Anonymous (IP-Adresse bekannt)
Datum: 06. Mai 2008 19:14

hallo,
Server läuft ... Group-e LDAP aktuellste version.
ist es eig auch möglich nun via smb protokol .. also von einem windows rechner über \\192.168.5.177\ an die hochgeladenen daten zu kommen? da dies bei mir nicht funktioniert wenn ich auch existirende system benutzer oder nen ldap benutzer wähle ..

oder allgemein über smb den server als datei server zu nutzen?

danke

lg



1-mal bearbeitet. Zuletzt am 26.09.12 14:49.

Re: samba zugriff auf den group-e server
geschrieben von: Anonymous (IP-Adresse bekannt)
Datum: 13. Mai 2008 17:12

Hallo,
Hat da keiner ne idee zu? oder denk ich einfach grundsätzlich falsch? muss dafür was anderes beachtet werden? oder wie was wo?

danke

lg



1-mal bearbeitet. Zuletzt am 26.09.12 14:50.

Re: samba zugriff auf den group-e server
geschrieben von: schmunzler (IP-Adresse bekannt)
Datum: 14. Mai 2008 10:21

Hi,

das hängt IMHO davon ab, welchen DateiManager Du verwendest - es gibt einen der Auf Samba Freigaben zugreift [Samba-Dateimanager], und einen internen der die Dateien innerhalb der Group-e Verzeichnisstruktur ablegt [Dateimanager].

Bei erstem wird mit den Rechten des angemeldeten Benutzers auf eine voreingestellte Samba-Freigabe zugegriffen.

Bei letzterem werden die Dateien mit einer Group-e internen Kennung umbenannt, so dass sich bei direktem Zugriff über das Dateisystem keine Rückschlüsse auf die Datei ziehen lassen. Aus diesem Grund kann ich von dem direkten Zugriff nur abraten.

Re: samba zugriff auf den group-e server
geschrieben von: Anonymous (IP-Adresse bekannt)
Datum: 15. Mai 2008 16:32

Hallo,
ok danke also das die dateien in group-e schon über den samba-dateimanager hochgeladen werden müssen is mir schon klar aber was nun meine eigendliche frage war wie ich via Explorer an die Daten komme? bei Eingeabe der ip mit vorangestellten backslashes also so: "\\192.168.5.177" da bekomm ich auch ne Anmeldeaufforderung die mich nach benutzer und kennwort frage so wie halt bei einer geschützten smb freigabe üblich. jedoch akzeptiert der meinen Benutzer scheinbar nicht. ich hab einen Benutzer namens test mit pw: testtest
als login varianten hab ich versucht: test, test.test, test@example.com, test.test@example.com
alle jedoch scheitern. woran kann das liegen oder gibt es da was, das ich grundsätzlich falsch verstehe?

lg



1-mal bearbeitet. Zuletzt am 26.09.12 14:52.

Re: samba zugriff auf den group-e server
geschrieben von: Support (IP-Adresse bekannt)
Datum: 15. Mai 2008 17:57

Hallo,
läuft Samba mit LDAP Backend ?
Hat der Benutzer Samba Rechte (Admin/BenutzerInnen) ?
Zeigt der Befehl "pdbedit -Lv" alle Benutzer an ?

Grüße Endo7 Team

Re: samba zugriff auf den group-e server
geschrieben von: Anonymous (IP-Adresse bekannt)
Datum: 16. Mai 2008 11:44

Hallo,

hier die ausgabe der abfrage:

root@group-e:/opt/group-e# pdbedit -Lv
---------------
Unix username: nobody
NT username: nobody
Account Flags: [NDU ]
User SID: S-1-5-21-2619833486-449048830-3385870200-2998
Primary Group SID: S-1-5-21-2619833486-449048830-3385870200-513
Full Name: nobody
Home Directory: \\LINUX\homes$\nobody
HomeDir Drive: U:
Logon Script: scripts\logon.bat
Profile Path: \\LINUX\profiles$\nobody
Domain: TEST
Account desc:
Workstations:
Munged dial:
Logon time: 0
Logoff time: never
Kickoff time: never
Password last set: 0
Password can change: 0
Password must change: 0
Last bad password : 0
Bad password count : 0
Logon hours : FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
root@group-e:/opt/group-e#


und hier der wichtige part der smb.conf. Muss ich dort vllt noch konkreteres einstellen?


1 unix charset = LOCALE
2 workgroup = TEST
3 netbios name = TEST_SRV
4 interfaces = eth0, lo
5 bind interfaces only = Yes
6 passdb backend = ldapsam:ldap://localhost
7 username map = /etc/samba/smbusers
8
9 log level = 0
10 syslog = 0
11 log file = /var/log/samba/%m
12 max log size = 50
13 name resolve order = wins bcast hosts
14 time server = Yes
15 printcap name = CUPS
16 show add printer wizard = No
17 add user script = /usr/sbin/smbldap-useradd -a -m '%u'
18 delete user script = /usr/sbin/smbldap-userdel '%u'
19 add group script = /usr/sbin/smbldap-groupadd -p '%g'
20 delete group script = /usr/sbin/smbldap-groupdel '%g'
21 add user to group script = /usr/sbin/smbldap-groupmod -m '%u' '%g'
22 delete user from group script = /usr/sbin/smbldap-groupmod -x '%u' '%g'
23 set primary group script = /usr/sbin/smbldap-usermod -g '%g' '%u'
24 add machine script = /usr/sbin/smbldap-useradd -w '%u'
25 logon script = scripts\logon.bat
26 logon path = \\%L\profiles\%U
27 logon drive = X:
28
29 os level = 64
30 preferred master = yes
31 domain master = yes
32 local master = yes
33 security = user
34 domain logons = Yes
35 preferred master = Yes
36 wins support = Yes
37 ldap suffix = dc=example,dc=com
38 ldap machine suffix = ou=Computers
39 ldap user suffix = ou=Users
40 ldap group suffix = ou=Groups
41 ldap idmap suffix = ou=Idmap
42 ldap admin dn = cn=admin,dc=example,dc=com
43 #ldap ssl = start tls
44
45 idmap backend = ldap:ldap://localhost
46 idmap uid = 10000-20000
47 idmap gid = 10000-20000
48
49 map acl inherit = Yes
50
51 enable privileges = yes



naja danke erstmal


lg Valentin



1-mal bearbeitet. Zuletzt am 26.09.12 14:50.

Re: samba zugriff auf den group-e server
geschrieben von: Support (IP-Adresse bekannt)
Datum: 16. Mai 2008 16:09

Hallo,
die User im LDAP Verzeichnis (wenn welche drin sind) werden nicht von Samba erkannt.
Wie sieht die Ausgabe mit "slapcat" aus. Erscheinen da die Benutzer ? Ist die Wurzel wirklich "dc=example,dc=com" ?

Grüße Endo7 Team

Re: samba zugriff auf den group-e server
geschrieben von: Anonymous (IP-Adresse bekannt)
Datum: 16. Mai 2008 16:35

Hallo,

ja also slapcat gibt folgendes aus:

[myhost]

sonst hier noch meine ldap struktur

vllt hilft das ja

[myhost]


ja doch die domäne ist example.com und das ganze soll noch keine produktiv umgebung werden erstmal nur um sich in group-e ein zu fuchsen ^^... desswegen example.com, sofern das teil dann funktioniert wirds nochmals neu aufgesetzt und ab dann produktiv genutzt.

danke

lg



1-mal bearbeitet. Zuletzt am 26.09.12 14:51.

Re: samba zugriff auf den group-e server
geschrieben von: Support (IP-Adresse bekannt)
Datum: 26. Mai 2008 22:08

Hallo,
die Benutzer im LDAP (test1 und test2) haben keine Samba Attribute. Deswegen erscheinen sie nicht mit pdbedit. Unter Admin/Benutzerinnen in Group-e bei den beiden die Samba Checkbox anklicken, dann gehts.

Grüße Endo7 Team

Re: samba zugriff auf den group-e server
geschrieben von: Anonymous (IP-Adresse bekannt)
Datum: 27. Mai 2008 16:51

HiHo,

sorry das ich mich solange nicht gemeldet hab.

aber ne also die checkboxen waren schon gesetzt. funktioniert trotzdem nicht! .. oder muss der anmeldename ein anders format haben?

bzw ncoh irgendwas so im samba eingestellt werden?

lg Vale



1-mal bearbeitet. Zuletzt am 26.09.12 14:53.

Re: samba zugriff auf den group-e server
geschrieben von: schmunzler (IP-Adresse bekannt)
Datum: 13. Juni 2008 14:48

Hallo,

bitte verwechsel nicht die beiden Dateimanager. Der eine gibt Dir einen Blick auf bereits vorhandene Samba-Freigaben, welche bereits existieren und auch im Windows Netzwerk genutzt werden.

Der andere hat mit Samba nichts zu tun. Die Dateien können im Browser per Fileupload hochgeladen werden und liegen lokal auf dem Group-e Server vor. Daher können sie in erster Linie nur von Group-e verwaltet werden. Wenn Du über eine Samba-Freigabe darauf zugreifen möchtest, dann musst Du diese in der Samba Konfiguration zusätzlich einrichten - dieses ist aber unabhängig von Group-e.

Siehe dazu auch [forum.group-e.info] und den Beitrag von xtra.



2-mal bearbeitet. Zuletzt am 13.06.08 14:51.



Ihr vollständiger Name: 
Ihre E-Mail-Adresse: 
Thema: 
Spamschutz:
Bitte gib den Code aus dem unten stehenden Bild in das Eingabefeld ein. Damit werden Bots, die versuchen dieses Formular automatisch auszufüllen, geblockt. Wenn der Code schwer zu lesen ist, versuche einfach zu raten. Wenn du einen falschen Code eingibst, wird einfach ein neues Bild erzeugt und du bekommst eine zweite Chance.