Synchronisierung z-push neue Version mit Android 2.2
geschrieben von: mmai (IP-Adresse bekannt)
Datum: 30. Mai 2011 18:06

Hallo Community,

habe group-e 1.72 im Einsatz und die letzte Version von z-push für group-e installiert.
z-push liegt im Verzeichnis /opt
Habe die Einträge /etc/apache2/apache2.conf lt. Doku gemacht.
Habe in der Datei /opt/z-push/config.php den Eintrag
define('GROUP_URL_PATH','/group-e/soap.php'); //for example '/group-e/soap.php'
überprüft

und dann noch mit [192.6.1.16]
kontrolliert ob der Zugriff grundsätzlich funktioniert.

Der Browser hat mich nach den Anmeldedaten gefragt und folgende Meldung ausgegeben:
GET not supported
This is the z-push location and can only be accessed by Microsoft ActiveSync-capable devices.

Ich denke das dies grundsätzlich passen müsste.

Ich schaffe es aber nicht mehr auch nur irgendwelche Daten zu synchronisieren.

Kein Eintrag in der /var/log/apache2/error.log
Kein Eintrag in der Daten /opt/z-push/debug.txt

Nur nach der Einrichtung unter Android und der erstmaligen Verbindung bzw.
wenn man die Einrichtung unter Android wiederholt werden meldungen in die
debug.txt geschrieben.

Die einzigen Zeilen die auf einen Fehler hinweisen könnten sind folgende:

[faultstring] => Function 'getActiveSyncSyncSettings' doesn't exist
[faultcode] => SOAP-ENV:Server
)

05/30/11 17:54:26 [3796] [mm] SoapFault Object
(
[message:protected] => Function 'getActiveSyncTimeZone' doesn't exist
[string:private] =>
[code:protected] => 0

Es gibt keine Zeile mit einem "error" in der debug.txt

Vielleicht hat jemand eine Idee wie ich es wieder zum Laufen bringen könnte.

Danke.

Re: Synchronisierung z-push neue Version mit Android 2.2
geschrieben von: schmunzler (IP-Adresse bekannt)
Datum: 30. Mai 2011 21:10

Hallo,

verwende bitte GROUP-E mit der dazu passenden z-Push Version (1.725; 2.1), da nur dort das GROUP-E-Backend und ggf. weitere Anpassungen enthalten sind. Vermutlich verwendest Du ein originales z-Push, was noch nicht auf GROUP-E angepasst/ abgestimmt ist.

Daher klappt der Zugriff auf die Schnittstelle, aber der Zugriff auf das erforderliche Backend fehlt.

Re: Synchronisierung z-push neue Version mit Android 2.2
geschrieben von: mmai (IP-Adresse bekannt)
Datum: 31. Mai 2011 08:58

Hallo schmunzler,

danke für deine schnelle Reaktion.

Ich habe z-push aus dem ordner group-e auf sourceforge heruntergeladen.

Das sollte doch passen?

Ordner:
[sourceforge.net]

File:
[sourceforge.net]

Re: Synchronisierung z-push neue Version mit Android 2.2
geschrieben von: schmunzler (IP-Adresse bekannt)
Datum: 03. Juni 2011 10:28

Hallo mmai,

ja das passt. Melde bitte als Feedback, ob es das Problem gelöst hat.

Ich hatte in Verbindung mit einem Android 2.2 Probleme bei der Synchronisation von Adressen, was aber an dem Adroid lag, da die z-Push Synchronisation mit anderen Geräten (iPhone, Windows Mobile) weiterhin klappte. Die Lösung war in diesem Fall ein Upgrade auf Android 2.2.1 - siehe [forum.group-e.info]

Re: Synchronisierung z-push neue Version mit Android 2.2
geschrieben von: mmai (IP-Adresse bekannt)
Datum: 08. Juni 2011 12:40

Hallo schmunzler,

danke für deine Antwort,
bezüglich Update habe ich das Problem, dass mir über Kies kein Update
angeboten wird. Ich habe ein A1-Handy mit Sim-lock und Branding.

Lt. Foren bietet A1 noch kein Update an, gibt es eine Alternative?

Kannst du mir ev. einen Link nennen mit dem ich das Update unabhängig von A1
machen könnte.

Danke.

mfg
mmai

Re: Synchronisierung z-push neue Version mit Android 2.2
geschrieben von: schmunzler (IP-Adresse bekannt)
Datum: 17. Juni 2011 16:31

Hallo mmai,

einen Link zu einer aktuellen Firmware kann ich Dir nicht nennen. Soweit ich weiß, gibt es ab Android 2.2.1 zwei Varianten das Update anzustoßen (zu mindesten bei meinem Galaxy S 9100)
1. über die Software des Smartphone Herstellers (Samsung Kies)
2. über das Smartphone: Einstellungen -> Telefoininfo -> Systemupdates

Allerdings hängt die Verfügbarkeit eines Updates von dem Provider und dem Hersteller des Smartphones ab. So sollen in DE Vodafone und T-Mobile Kunden bereits Gingerbred (2.3.3) erhalten, während E-Plus/ Base noch nicht soweit ist. Also hilft nur abwarten.

Sollte gar kein Upgrade verfügbar sein, kannst Du eine alternative Firmware aufspielen. Empfehlen kann ich Dir dazu das aktuelle Sonderheft der c't [www.heise-shop.de]

Re: Synchronisierung z-push neue Version mit Android 2.2
geschrieben von: mmai (IP-Adresse bekannt)
Datum: 11. August 2011 15:37

Hallo Schmunzler,

habe jetzt nach dem Urlaub ein Update von meinem Provider zur Verfügung
gestellt bekommen.

Ich arbeite jetzt mit Android 2.3.3, das Synchronisieren scheint wieder
zu funktionieren.

Danke für deine Unterstützung, einen schönen Sommer bzw. Urlaub wünsche ich.

mfg
Manfred



Ihr vollständiger Name: 
Ihre E-Mail-Adresse: 
Thema: 
Spamschutz:
Bitte gib den Code aus dem unten stehenden Bild in das Eingabefeld ein. Damit werden Bots, die versuchen dieses Formular automatisch auszufüllen, geblockt. Wenn der Code schwer zu lesen ist, versuche einfach zu raten. Wenn du einen falschen Code eingibst, wird einfach ein neues Bild erzeugt und du bekommst eine zweite Chance.