Synchronisation mit z-push - kein login mehr
geschrieben von: Manfred Priller (IP-Adresse bekannt)
Datum: 28. Juni 2010 17:11

Hallo, habe z-push laut Anleitung in group-e integriert; habe auch eine Synchronisation hinbekommen (zumindest laut Telefon)

Wenn ich jetzt allerdings versuche über das Webfrontend mit dem user einzusteigen, sehe ich, dass der Browser arbeitet (Fortschrittsbalken...), allerdings werde ich nicht eingelogt, und das schlimme ist, dass der zuständige apache-prozess auf 100% ist. Im Apache-Log wird leider gar nichts geschrieben.

Ein strace auf den apache-Prozess gibt dauernd Zeilen à la
time(NULL) = 1277737775
time(NULL) = 1277737775
time(NULL) = 1277737776
...

Kann ich den user irgendwie resetieren?

Danke

Re: Synchronisation mit z-push - kein login mehr
geschrieben von: Manfred Priller (IP-Adresse bekannt)
Datum: 28. Juni 2010 18:22

Nachtrag:

Habe über den sysadmin das "Passwort verfällt nach" auf 1 Monat gesetzt, und bin dadurch beim Einsteigen mit dem blockierten User sofort in die Einstellungen gekommen. Nach durchklicken der einzelnen Module habe ich feststellen können, dass der Kalender und damit auch die Portalseite Schuld sind.

Kann ich den Kalender zurücksetzen/löschen?

Re: Synchronisation mit z-push - kein login mehr
geschrieben von: Support (IP-Adresse bekannt)
Datum: 29. Juni 2010 08:04

Hallo Manfred,

den Kalender zurücksetzten ist etwas schwierig.

Könntest du uns eventuell einen Dump folgender Tabellen schicken?
Einfach direkt an group-e@endo7.com

"CalEvent" und "SyncDevices"

Uns würde nämlich interessieren was da bei der Synchronisation schiefgelaufen sein könnte, denn dieser Fehler ist uns bisher nicht bekannt.

Welches Mobil-Gerät hast du denn verwendet?

Welche Installationvariante verwendest du ? (LDAP oder MYSQL).

Re: Synchronisation mit z-push - kein login mehr
geschrieben von: Support (IP-Adresse bekannt)
Datum: 30. Juni 2010 12:41

Irgendwie schickt der Mobile Client jährlich wiederkehrende Events nicht als jährlich wiederkehrend sondern als monatlich wiederkehrend. Wäre ja nicht das Problem wenn er als Intervall dann 12 schicken würde aber leider kommt als Intervall in Group-E 127 an was dann bei der Beruchnung der Wiederholungen schwierigkeiten macht.

Als schnelle Hilfe sollte folgendes SQL Statement den Kalender wieder in Ordnung bringen:

UPDATE CalEvent SET RecType=5,RecInt=1 WHERE RecType=3 AND RecInt=127;


Für die genaue Ursache müssen wir erst weitertesten und den Schuldigen ausmachen.

Re: Synchronisation mit z-push - kein login mehr
geschrieben von: Manfred Priller (IP-Adresse bekannt)
Datum: 05. Juli 2010 14:14

Hallo,

a) das Statement hat mein Problem glöst, ich kann wieder normal einsteigen.
(evtl. würde ich noch die OwnerID in die where-Klauser mitaufnehmen, damit es sicher nur für einen User ausgeführt wird?)

b) zur Ursache:
Bin wahrscheinlich selber Schuld, und das gleiche wird anderen Usern wahrscheinlich gar nicht passieren. Euer Tipp mit dem Intervall 12 hat mich stutzig gemacht; habe mir die Kalendereinträge im Telefon/Outlook nochmal angeschaut. Hatte fast alle jährlichen Einträge mit Typ Jährlich, aber Intervall 12 (Jahre). Wahrscheinlich ist bei den x synchronisierungen, die ich gemacht habe (mehrmalige Telefon- und Clientwechsel) irgendwann etwas schief gelaufen, und mir ist es nie richtig aufgefallen. Jedenfalls, die Daten waren schon vor der Synchronisierung fehlerhaft.

Danke nochmal für die Hilfe

Manfred



Ihr vollständiger Name: 
Ihre E-Mail-Adresse: 
Thema: 
Spamschutz:
Bitte gib den Code aus dem unten stehenden Bild in das Eingabefeld ein. Damit werden Bots, die versuchen dieses Formular automatisch auszufüllen, geblockt. Wenn der Code schwer zu lesen ist, versuche einfach zu raten. Wenn du einen falschen Code eingibst, wird einfach ein neues Bild erzeugt und du bekommst eine zweite Chance.